centos 8下php7.3安裝php-devel遇到的問題

語言: CN / TW / HK

因為需要安裝擴充套件要用到phpize,phpize又是依賴於php-devel 所以用yum安裝一下 發生錯誤

缺少libedit-devel(x86-64)包 

https://centos.pkgs.org/8/centos-powertools-x86_64/libedit-devel-3.1-23.20170329cvs.el8.x86_64.rpm.html 此網站下載對應的包

下載後 用 rpm -ivh libedit-devel-3.1-23.20170329cvs.el8.x86_64.rpm 解包?

發現缺少依賴 ncurses-devel(x86-64)

繼續去 https://pkgs.org/ 尋找依賴 wget下載解包 

 

又缺少依賴ncurses-c++-libs(x86-64) 繼續 下載解包  總算可以了  一步一步解包

完成 yum install php-devel