解決Yarn安裝less和sass後報錯 Syntax Error: TypeError: this.getOptions is not a function

語言: CN / TW / HK

問題: 在使用vue-cli搭建項目,安裝less-loader、sass-loader使用以下命令:

yarn add -D less-loader less
yarn add -D sass-loader sass
啟動項目的時候卻發現報錯,如下:

解決方案
安裝低一點版本的依賴包,目前7.3.0 以下測試可行.

先移除

yarn remove less-loader
yarn remove sass-loader

再重新安裝

yarn add -D [email protected]
yarn add -D [email protected]

更換版本之後再次運行項目即可。