Hyperledger Fabric V1.4– 快速上手

語言: CN / TW / HK

安裝前置條件

安裝Fabric1.4需要滿足以下條件:    

  1. 安裝有最新版本的CURL

  2. 安裝有docker以及docker-compose #V1.14或更高版本

  3. 安裝有Go 1.12+

  4. 正確設定GOPATH環境變數

  5. 安裝有libtool和libtdhl-dev包

  6. 使用下面的命令在ubuntu上安裝libtool依賴:

  7. 正確安裝node.js和Npm

安裝示例、二進位制檔案和 Docker 映像

curl -sSL http://bit.ly/2ysbOFE | bash -s -- <fabric_version> <fabric-ca_version> <thirdparty_version>
curl -sSL http://bit.ly/2ysbOFE | bash -s -- 1.4.12 1.4.9 0.4.22

如果執行上述 curl 命令時遇到錯誤,則可能是curl 版本太舊,更新新版 curl 或者替換未縮短的URL:

https://raw.githubusercontent.com/hyperledger/fabric/master/scripts/bootstrap.sh

命令下載並執行一個 bash 指令碼,該指令碼將下載二進位制檔案: 並將它們放在 bin 目錄中。

  • configtxgen ,

  • configtxlator ,

  • cryptogen ,

  • discover ,

  • idemixgen ,

  • orderer ,

  • peer ,

  • fabric-ca-client ,

  • fabric-ca-server

新增PATH 環境變數:

export PATH=<path to download location>/bin:$PATH